icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.adbba.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

头彩彩票 www.513382.com-口袋彩票被禁了| www.58786.com-福彩独胆定胆| www.068307.com-福彩快三百度百科| www.377390.com-彩票咋买-| www.637485.com-体彩6加1开奖查询| www.781746.com-自己开个彩票服务器| www.920769.com-双彩论坛字迷区| www.41ao.com-体彩票中奖-| www.28369.cc-彩票大乐透怎么玩| www.516950.com-彩票测试大师| www.622387.com-明发彩票官网| www.953994.com-网上计划彩票| www.cp5252.cc-爱彩乐江苏快三| www.641814.com-彩城彩票是真的吗| www.126039.com-福′彩手机报下载| www.207121.com-凤凰彩票提现失败| www.300303.com-下载快三走势图表| www.381527.com-第19011期体彩| www.502578.com-网聊男性劝我买彩票| www.577788.com-内蒙古快三新玩法| www.257900.com-福利快三充值券| www.874389.com-江苏福彩抉3一定牛| www.971617.com-泰安体彩3亿| www.635651.com-a7彩票-| www.886327.com-王者彩吧app| www.961753.com-福彩二星缩水软件| 中彩网www.81233v.com| www.ll69.com-01彩票平台合法吗| www.607916.com-app彩友多-| www.96515.cc-竞猜型彩票的规则| www.140.tv-带有彩虹的网名| www.9kr.com-四川福彩手机报下载| www.84kf.com-篮球彩票大小分结果| www.708466.com-探探男彩票托| www.792565.com-民政部彩票中心冯| www.871468.com-体彩藏机图今天| www.947512.com-外围足彩怎么投注| www.997387.com-彩票360下载安装| www.dy41.com-共赢联盟群cp彩票| www.wl60.com-高频彩票走势大全| www.1970.vip-彩票什么是龙| www.69440.com-多赢彩票-| www.23594.com-四季彩黑钱不| www.51279.cc-广西快三计划全天| www.069448.com-彩神iapp-| www.35419.com-代买彩票忘了打了| www.980323.com-体彩河南游泳| www.h42.com-免费彩票资料大全| www.472444.com-彩票软件吧-| www.099035.com-网易彩票靠谱不| www.522555.com-新未来分分彩| www.100879.com-在手机上能买彩票吗| www.012982.com-97彩票兼职可靠吗| www.100169.com-一定牛彩票能提现吗| www.35ei.com-彩票双色球中奖新闻| www.168801.com-安徽快三开奖结果今| www.16357.cc-彩客app正规吗| www.687079.com-哪里的彩票销售系统| www.88fs.com-体彩大乐透中奖情况| www.98672.com-彩云追星七星彩最新| www.448335.com-彩票站代买-| www.983143.com-38彩平台-| www.cp03.com-江苏体彩11选5| www.x26.net-体彩排三杀码预测| www.017673.com-易彩国际app| www.980157.com-彩票账对不上| www.510713.com-六色彩虹意义| www.234191.com-芜湖市福利彩票中心| www.644407.com-下载华亿彩票app| www.705928.com-下载发彩-| www.779270.com-彩票开户ok168| www.838162.com-彩39彩票下载| www.900249.com-陌陌彩票注册送28| www.955417.com-彩票概率公式| www.999568.com-福彩走势两千期| www.bz05.com-快三平台介绍| www.sn54.com-时时彩包胆计划技巧| www.4as.com-德惠彩票站-| www.55cf.com-都匀彩票店位置| www.208230.com-快三网上投注| www.cai0111.com北京快三一定牛| www.93pj.cc-分分彩如何看号| www.157755.com-竞彩盈亏指数| www.256098.com-重庆时时彩几点结束| www.434372.com-福彩面试些什么| www.3030.mobi-快三开奖程序| www.828365.com-福彩3d追号计算器| www.981250.com-足彩14场开奖最快| www.668490.com-在国外做彩票合法吗| www.631007.com-彩运宝清风-| www.706030.com-官网国乐彩-| www.050685.com-体彩自动售票机加盟| www.77289.cc-彩客网苹果版| www.ie22.com-白岩松回应彩票| www.13554.com-合肥福彩加盟电话| www.563815.com-七乐彩谜语-| www.o51.cn-新浪彩票新浪网| www.479366.cc-百度体彩大乐透| www.911235.cc-k彩下载网址| www.380729.com-云南彩票大王| www.130664.com-买彩票中奖顺口溜| www.449950.com-博彩高倍-| www.567753.com-卖彩票的广告词语| www.654547.com-江西上饶福彩中心| www.731126.com-易彩快3预测| www.804231.com-体彩大乐透买法| www.875654.com-高赠送彩票平台| www.975376.com-微信退款致富彩票| www.gs76.com-好彩蓝莓双爆珠价格| www.34cw.com-时时彩网站建设教程| www.134.date-本子漫画全彩图片| www.021831.com-258竞彩足球官方| www.098729.com-电脑彩-| www.237571.com-幸运快三走势图软件| www.055565.com-福建快三预测号码| www.121148.com-体彩排列五选号软件| www.6542.net-彩票猜大小单双窍门| www.192219.com-彩票app大全下载| www.519210.com-3d家彩开机号| www.589070.com-彩客足球竞彩| www.860746.com-快三2同号-| www.936647.com-爱刮刮的彩票成本| 福彩www.26878m.com| www.046170.com-657彩票k-| www.981394.com-众博彩票app下载| www.003564.com-盈彩网充值-| www.9147.online七乐彩去哪里领奖| www.774410.com-彩漫母穴后篇71| www.970908.com-迷彩兔播放器| www.wt11.cc-无需申请免费送彩金| www.502248.com-五分钟一期彩票骗局| www.571879.com-体彩假吗-| www.633396.com-分分彩雪球-| www.697001.com-网上彩票站下载| www.760255.com-釉彩大瓶展出| www.824997.com-山西体育彩票网站| www.887589.com-彩票中奖怎么兑奖| www.957605.com-体彩北京领奖地址| 中国福利彩票www.3478a.cc| www.388276.com-67彩合法吗-| www.729271.com-神彩通4码-| www.794518.com-重庆时时彩黑客名单| www.89786.com-网购双色球彩票| www.088810.com-福彩快三安全吗| www.559126.com-赤峰体育彩票| www.861361.com-安徽体育彩票网| www.950751.com-体彩不败胆码| 福彩网www.5522d.cc| www.623702.com-盈盛彩票网站| www.761009.com-足彩十四场专家预测| www.919805.com-自己打印彩票| www.lh69.com-彩八万下载安装| www.859556.com-内蒙古体彩遗漏| www.962658.com-快三守号260计划| www.cai2222.cc-福彩北京快三开奖号| www.171279.com-河北快三二同号推荐| www.237806.com-上海快三开今天结果| www.42qf.com-搭彩钢棚图片| www.830794.com-手机彩票开奖| www.556810.com-苹果彩票彩app| www.579124.com-福彩电话投注中奖| www.qn36.com-彩票社会责任| www.103922.com-彩票最低中奖多少钱| www.844633.com-年底彩票什么时候停|